f
Warning: Cannot modify header information - headers already sent by (output started at /home/anderian/ftp/www_forum/db/mysql4.php:1) in /home/anderian/ftp/www_forum/includes/sessions.php on line 548

Warning: Cannot modify header information - headers already sent by (output started at /home/anderian/ftp/www_forum/db/mysql4.php:1) in /home/anderian/ftp/www_forum/includes/sessions.php on line 549

Warning: Cannot modify header information - headers already sent by (output started at /home/anderian/ftp/www_forum/db/mysql4.php:1) in /home/anderian/ftp/www_forum/includes/page_header.php on line 343
And-Tech :: Zobacz temat - AND-Graph132 dziwny błąd kompilatora.

Strona korzysta z plików cookie w celu realizacji usług zgodnie z Politykš prywatnoœci.

Możesz okreœlić warunki przechowywania lub dostępu do cookie w Twojej przeglšdarce lub konfiguracji usługi.

And-Tech Strona Główna And-Tech
Forum firmy And-Tech

FAQFAQ  SzukajSzukaj  UżytkownicyUżytkownicy  GrupyGrupy
RejestracjaRejestracja  ZalogujZaloguj  AlbumAlbum  DownloadDownload

Poprzedni temat «» Następny temat
Przesunięty przez: piotr94
Wto Maj 08, 2012 9:55 am
AND-Graph132 dziwny błąd kompilatora.
Autor Wiadomość
guru 

Dołączył: 25 Lis 2009
Posty: 29
Wysłany: Wto Maj 08, 2012 9:27 am   AND-Graph132 dziwny błąd kompilatora.

Witam.
Zacząłem zabawę AND-Graph132.
Niestety tylko jeden kod z kursy kompiluje mi się prawidłowo k1.bas
Kod:
'$regfile = "m644pdef.dat"
$regfile = "m32def.dat"
'$regfile = "m16def.dat"

$baud = 9600

$crystal = 16000000

$lib "lcd-pcf8833.lbx"
(...proszę nie rozpowszechniać kodów z kursu...)


Niestety każdy następny zwraca komunikat:
"Error 61: Line: 100 Label not found [_BOX ]"
NIestety w pliku nie ma linii 100 :(
k2.bas

Kod:
'$regfile = "m644pdef.dat"
$regfile = "m32def.dat"
'$regfile = "m16def.dat"

$baud = 9600

$crystal = 16000000

$lib "lcd-pcf8833.lbx"
(...proszę nie rozpowszechniać kodów z kursu...)


Co to może być??
Windows 7P 64, pliki z fontami i biblioteka znajdują się tam gdzie potrzeba.
Ostatnio zmieniony przez piotr94 Wto Maj 08, 2012 9:59 am, w całości zmieniany 2 razy  
 
 
     
piotr94 
Site Admin

Dołączył: 02 Lut 2010
Posty: 606
Skąd: Kraków
Wysłany: Wto Maj 08, 2012 9:58 am   

1. Bardzo proszę nie rozpowszechniać całych kodów z kursu.
2. Proszę o podanie wersji Bascom, skompilowałem Pana kody na wersji 1.11.9.8 (zalecana dla kursu, pełna wersja) i nie ma żadnego błędu.
_________________
http://www.piotr94.net21.pl/
 
     
guru 

Dołączył: 25 Lis 2009
Posty: 29
Wysłany: Sro Maj 09, 2012 5:46 am   

Na mojej 1.11.9.0 niestety taki błąd wyskakuje.
 
 
     
piotr94 
Site Admin

Dołączył: 02 Lut 2010
Posty: 606
Skąd: Kraków
Wysłany: Sro Maj 09, 2012 11:59 am   

Czy to pełna wersja, czy demo? Proszę o dokonanie aktualizacji BASCOMA do wersji minimum 1.11.9.8 (na takiej testowałem kurs), lub najnowszej dostępnej u producenta kompilatora (2.x.x.x). Nic więcej w tej sytuacji nie mogę pomóc - to wina kompilatora, nie mam nawet dostępu do Pana wersji w swoich archiwach.
_________________
http://www.piotr94.net21.pl/
 
     
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group