f
Warning: Cannot modify header information - headers already sent by (output started at /home/anderian/ftp/www_forum/db/mysql4.php:1) in /home/anderian/ftp/www_forum/includes/sessions.php on line 548

Warning: Cannot modify header information - headers already sent by (output started at /home/anderian/ftp/www_forum/db/mysql4.php:1) in /home/anderian/ftp/www_forum/includes/sessions.php on line 549

Warning: Cannot modify header information - headers already sent by (output started at /home/anderian/ftp/www_forum/db/mysql4.php:1) in /home/anderian/ftp/www_forum/includes/page_header.php on line 343
And-Tech :: Zobacz temat - AVRProg MKII - aktualizacje firmware

Strona korzysta z plików cookie w celu realizacji usług zgodnie z Politykš prywatnoœci.

Możesz okreœlić warunki przechowywania lub dostępu do cookie w Twojej przeglšdarce lub konfiguracji usługi.

And-Tech Strona Główna And-Tech
Forum firmy And-Tech

FAQFAQ  SzukajSzukaj  UżytkownicyUżytkownicy  GrupyGrupy
RejestracjaRejestracja  ZalogujZaloguj  AlbumAlbum  DownloadDownload

Poprzedni temat «» Następny temat
AVRProg MKII - aktualizacje firmware
Autor Wiadomość
piotr94 
Site Admin

Dołączył: 02 Lut 2010
Posty: 606
Skąd: Kraków
  Wysłany: Wto Lis 06, 2012 6:09 pm   AVRProg MKII - aktualizacje firmware

Witam wszystkich użytkowników programatora!

W tym wątku będą zamieszczane sprawdzone kompilacje firmware dla programatora AVRProg MKII.

Firmware programatora bazuje na firmware LUFA: http://www.fourwalledcubicle.com/LUFA.php
Na podanej stronie (dołączony do przykładów wykorzystania biblioteki) można znaleźć zawsze najnowsze kody źródłowe oprogramowania dla programatora.

Instrukcja aktualizacji/zmiany oprogramowania: http://and-tech.pl/wp-con...mkii%20v1.0.pdf (od strony 14).

W tym wątku prosimy o zamieszczanie pytań tylko i wyłącznie związanych z aktualizacją oprogramowania i problemach z najnowszym firmware.
Zanim zgłosisz błąd i poprosisz o pomoc wgraj aktualną wersję oprogramowania i sprawdź czy Twój problem nie został już rozwiązany.

Zawsze pamiętaj o przeczytaniu całego wątku i pobraniu ostatniego z załączonych firmware.

---Dodano 28.08.2013---
UWAGA!!!
Najnowszy firmware - Wersja LUFA: 130901 (build 132808) - oraz wszystkie następne będą dostarczane z 3 wsadami.
Poszczególne wsady są przeznaczone odpowiednio dla:
AVRISP-MKII_LUFAxxxxxx_NORMAL_BASCOM.hex - programator standardowy (z 2 złączami), współpraca z BASCOM AVR, AVRDude i innymi programami opartymi o libusb
AVRISP-MKII_LUFAxxxxxx_NORMAL_STUDIO.hex - programator standardowy (z 2 złączami), współpraca z AVR/Atmel Studio
AVRISP-MKII_LUFAxxxxxx_ECO.hex - programator w wersji ECO (z 1 złączem - tylko ISP), współpraca z AVR/Atmel Studio i BASCOM AVR/AVRDude przełączana przełącznikiem

UWAGA!!!
Nie wolno pomylić firmware dla wersji NORMAL i ECO - może to skutkować uszkodzeniem programatora.
Zawsze DWUKROTNIE upewnij się, że wgrywasz odpowiedni firmware.
Podobnie użycie naszego firmware ze sprzętem innego producenta może spowodować jego uszkodzenie - umieszczone tu wsady przeznaczone sa tylko dla oryginalnych produktów firmy And-Tech


----------
Lista firmware:
05.11.2012: Wersja LUFA: 120730 (build 121105)
30.03.2013: Wersja LUFA: 130303 (build 130304)
28.08.2013: Wersja LUFA: 130901 (build 132808)
28.09.2014: Wersja LUFA: 140928 (build 140928)
21.10.2015: Wersja LUFA: 140928 (build 151023)

AVRISP-MKII_LUFA140928_FW1.18_BUILD151023.zip
Wersja LUFA: 140928 (build 151023)
Wersje:
*NORMAL: AVR/Atmel Studio (F/W: 1.18) *NORMAL: BASCOM/AVRDude
*ECO: AVR/Atmel Studio (F/W: 1.18) + BASCOM/AVRDude (Switch)
Pobierz Plik ściągnięto 1020 raz(y) 30,71 KB

AVRISP-MKII_LUFA140928_BUILD140928.zip
Wersja LUFA: 140928 (build 140928)
Wersje:
*NORMAL: AVR/Atmel Studio (F/W: 1.17) *NORMAL: BASCOM/AVRDude
*ECO: AVR/Atmel Studio (F/W: 1.17) + BASCOM/AVRDude (Switch)
Stary firmware - użycie niezalecane
Pobierz Plik ściągnięto 721 raz(y) 30,67 KB

AVRISP-MKII_LUFA130901_BUILD130828.zip
Wersja LUFA: 130901 (build 132808)
Wersje:
*NORMAL: AVR/Atmel Studio (F/W: 1.17) *NORMAL: BASCOM/AVRDude
*ECO: AVR/Atmel Studio (F/W: 1.17) + BASCOM/AVRDude (Switch)
Stary firmware - użycie niezalecane
Pobierz Plik ściągnięto 876 raz(y) 30,32 KB

AVRISP-MKII_130303_BASCOM_STUDIO.zip
Wersja LUFA: 130303 (build 130304)
Wersje: AVRStudio i AVRDude
Stary firmware - użycie niezalecane
Pobierz Plik ściągnięto 947 raz(y) 20,09 KB

AVRISP-MKII_LUFA120730_build_121105.zip
Wersja LUFA: 120730 (build 121105)
Wersje: AVRStudio i AVRDude
Stary firmware - użycie niezalecane
Pobierz Plik ściągnięto 1023 raz(y) 20,11 KB

_________________
http://www.piotr94.net21.pl/
Ostatnio zmieniony przez piotr94 Pią Paź 23, 2015 12:15 am, w całości zmieniany 5 razy  
 
     
piotr94 
Site Admin

Dołączył: 02 Lut 2010
Posty: 606
Skąd: Kraków
Wysłany: Czw Kwi 04, 2013 10:54 pm   

Wersja BETA, rozwiązuje tymczasowo problemy z najnowsza wersją Atmel Studio 6, wymagającą firmware w wersji 1.15.
----
Załącznik skasowany -> http://forum.and-tech.pl/viewtopic.php?p=3916#3916
_________________
http://www.piotr94.net21.pl/
Ostatnio zmieniony przez piotr94 Sro Sie 28, 2013 7:43 pm, w całości zmieniany 2 razy  
 
     
igi79

Dołączył: 30 Maj 2013
Posty: 2
Wysłany: Czw Maj 30, 2013 8:09 pm   

Guys, sorry for english, but Im from Slovakia and my polish is very bad.
Can you fix firmware version: -
I have windows 8 64-bit and Jungo drivers 11.0.0.0 (27.2.2012) and AtmelStudio 6.1 show this with your last BETA.

Or can you advise which USB driver I have to use to get this working in W8.

Capture.PNG
studio
Plik ściągnięto 18708 raz(y) 6,68 KB

 
     
piotr94 
Site Admin

Dołączył: 02 Lut 2010
Posty: 606
Skąd: Kraków
Wysłany: Czw Maj 30, 2013 11:38 pm   

Hi, another workaround firmware attached - fixing problems with the 1.16 firmware requirement.
Your problem is caused by the old firmware version stored in firmware. If You see the message there is no problem with drivers - please use attached firmware and let us know if everything works correctly.
----
Załącznik skasowany -> http://forum.and-tech.pl/viewtopic.php?p=3916#3916
_________________
http://www.piotr94.net21.pl/
Ostatnio zmieniony przez piotr94 Sro Sie 28, 2013 7:43 pm, w całości zmieniany 1 raz  
 
     
igi79

Dołączył: 30 Maj 2013
Posty: 2
Wysłany: Pią Maj 31, 2013 1:45 am   

Great, it is working!
Thank you very much.
 
     
atomicus

Dołączył: 11 Lis 2013
Posty: 1
Wysłany: Pon Lis 11, 2013 5:14 pm   

Witam.

Po instalacji Atmel Studio 6.1sp2
Oraz dodatku AtmelUSB dla Windows8.1 programator nie instaluje się

System wykrywa go jako nieznane urządzenie isp mk2, jednak nie instaluje sterowników.
Po ręczynm wybraniu sterowników (Wybrano Jungo Comuniations - WinDriver) programator jest widoczny w Atmel Studio, można programować fuse bity, odczytuje poprawnie sygnaturę uC, ale już źle napięcie (mam atmege32, która jest 5v, odczyt jes 3.3v).

Przy próbie programowania, dostaję błąd ispProgramMem: Error status received: Got 0x80, expected 0x00

Wszystko na Win8.1
Programator ma najnowszą lufę.
 
     
piotr94 
Site Admin

Dołączył: 02 Lut 2010
Posty: 606
Skąd: Kraków
Wysłany: Wto Lis 12, 2013 6:29 pm   

Hmm,
Po kolei:
1. Napięcie 3,3V będzie wyświetlane zawsze - programator nie dokonuje pomiaru napięcia, ale zawsze podaje w środowisku informację o napięciu 3,3V.
2. Problem z programowaniem może leżeć zarówno po stronie systemu (niestety W8 to kolejny Vistopodobny bubelek) jak i podłączenia procesora do programatora (np. niepołączenie mas, nieprawidłowe zasilenie procesora, ...)
_________________
http://www.piotr94.net21.pl/
 
     
piotr94 
Site Admin

Dołączył: 02 Lut 2010
Posty: 606
Skąd: Kraków
Wysłany: Nie Wrz 28, 2014 7:35 pm   

Najnowszy firmware oparty na dziś wydanej aktualizacji LUFY opublikowany w pierwszym poście - zapraszam do zmiany oprogramowana.
_________________
http://www.piotr94.net21.pl/
 
     
piotr94 
Site Admin

Dołączył: 02 Lut 2010
Posty: 606
Skąd: Kraków
  Wysłany: Pią Sie 14, 2015 3:50 pm   

UWAGA!
Najnowsze Atmel Studio (6.2sp2 build1563) wydaje się mieć błąd, powodujący na niektórych komputerach (z testowanych przez nas sprzętów ok. 50%) brak komunikacji z programatorem zakończony błędem:
Kod:

Read from USB device endpoint 130 failed: HCD: Transfer submitted to a stalled endpoint (0xc0000030).

lub:
Kod:

Could not establish communication with the tool.

W przypadku wystąpienia takiego błędu, jeśli już wyeliminujecie niepraiwdłowo wybrany firmware (AVRDUDE lub STUDIO), zalecamy korzystanie ze starszej wersji środowiska - 6.2sp1 build1153:
http://www.atmel.com/Images/AStudio6_2_1153net.exe

Czasem problem występuje tylko przy podłaczeniu przez huby USB. jeśli tak podłączacie swój programator a chcecie korzystać z najnowszej wersji środowiska zalecamy najpierw sprawdzenie podłączenia z pominięciem hubów.

Ponadto problem zgłosiliśmy już do Autora projektu LUFA.
_________________
http://www.piotr94.net21.pl/
 
     
piotr94 
Site Admin

Dołączył: 02 Lut 2010
Posty: 606
Skąd: Kraków
Wysłany: Pią Paź 23, 2015 12:17 am   

Podobny problem mamy też z Atmel Studio 7.0.
W pierwszym poście aktualizacja Firmware pozwalająca ominąć problem żądania aktualizacji oprogramowania - wersja eksperymentalna.
_________________
http://www.piotr94.net21.pl/
 
     
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group